container_background

TYPO3 Backend ohne Funktion nach PHP Update auf 5.5.6

Offizielle Fehlermeldung: $toolbarItem "shortcuts" must implement interface TYPO3\CMS\Backend\Toolbar\ToolbarItemHookInterface To reproduce, create a new 6.2 installation using the wizard in the install tool, and run it on PHP 5.5.6

Zur Zeit kommt es zu massiven Problemen bei vielen TYPO3 Installationen.
Nach dem Login kommt es zu folgender Fehlermeldung:

$toolbarItem "shortcuts" must implement interface TYPO3\CMS\Backend\Toolbar\ToolbarItemHookInterface To reproduce, create a new 6.2 installation using the wizard in the install tool, and run it on PHP 5.5.6

Grund ist ein Problem mit PHP. In den meisten Fällen wurde ein Update durch den Hosting-Dienstleister ausgeführt, anschließend tritt die Komplikation auf. Diese erste Erkenntnis läßt vermuten, dass der Fehler nicht auf Seiten von TYPO3 liegt. Nach unserem Kenntnisstand besteht die Problematik ab der TYPO3 Version 4.x bis 6.x.

Der Bug ist bereits in der TYPO3 Forge bekannt und wird bearbeitet: http://forge.typo3.org/issues/53682

Die zum jetzigen Zeitpunkt vermeintliche beste Lösung ist mit der betroffenen Website auf einen Server zu wechseln, der eine alte PHP Version benutzt. Ebenfalls zu einem hilfreichen Ergebnis führt, die Website bei einem Hoster, der keine automatischen PHP Updates durchführt, zu betreiben.

Zugegebener Maßen sind diese Handlungsweise keine sehr elegante Lösungen, daher werden auch wir auf weitere Aufklärungen gespannt sein.